Gmail’s blog telling me I need a “modern browser” on my iPad (4.3). SERIOUSLY?

Gmail’s blog telling me I need a “modern browser” on my iPad (4.3). SERIOUSLY?